kde-frameworks: 5.40.0 amd64 stable, bug #639542
[gentoo.git] / kde-frameworks / kpeople / kpeople-5.37.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5
8
9 DESCRIPTION="KDE contact person abstraction library"
10 HOMEPAGE="https://projects.kde.org/projects/frameworks/kpeople"
11
12 LICENSE="LGPL-2.1"
13 KEYWORDS="amd64 ~arm x86"
14 IUSE=""
15
16 DEPEND="
17         $(add_frameworks_dep kconfig)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep ki18n)
20         $(add_frameworks_dep kitemviews)
21         $(add_frameworks_dep kservice)
22         $(add_frameworks_dep kwidgetsaddons)
23         $(add_qt_dep qtdbus)
24         $(add_qt_dep qtdeclarative)
25         $(add_qt_dep qtgui)
26         $(add_qt_dep qtsql)
27         $(add_qt_dep qtwidgets)
28 "
29 RDEPEND="${DEPEND}
30         !net-libs/kpeople:5
31 "
32
33 src_test() {
34         # bug: 612504
35         local myctestargs=( -j1 )
36
37         kde5_src_test
38 }