kde-frameworks/knotifications: x86 stable wrt bug #724346
[gentoo.git] / kde-frameworks / knotifications / knotifications-5.70.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_TEST="false"
7 PVCUT=$(ver_cut 1-2)
8 QTMIN=5.12.3
9 inherit ecm kde.org
10
11 DESCRIPTION="Framework for notifying the user of an event"
12 LICENSE="LGPL-2.1+"
13 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
14 IUSE="dbus nls phonon speech X"
15
16 BDEPEND="
17         nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
18 "
19 RDEPEND="
20         =kde-frameworks/kconfig-${PVCUT}*:5
21         =kde-frameworks/kcoreaddons-${PVCUT}*:5
22         =kde-frameworks/kwindowsystem-${PVCUT}*:5
23         >=dev-qt/qtdbus-${QTMIN}:5
24         >=dev-qt/qtgui-${QTMIN}:5
25         >=dev-qt/qtwidgets-${QTMIN}:5
26         dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
27         !phonon? ( media-libs/libcanberra )
28         phonon? ( media-libs/phonon[qt5(+)] )
29         speech? ( >=dev-qt/qtspeech-${QTMIN}:5 )
30         X? (
31                 >=dev-qt/qtx11extras-${QTMIN}:5
32                 x11-libs/libX11
33                 x11-libs/libXtst
34         )
35 "
36 DEPEND="${RDEPEND}
37         X? ( x11-base/xorg-proto )
38 "
39
40 src_configure() {
41         local mycmakeargs=(
42                 $(cmake_use_find_package dbus dbusmenu-qt5)
43                 $(cmake_use_find_package !phonon Canberra)
44                 $(cmake_use_find_package speech Qt5TextToSpeech)
45                 $(cmake_use_find_package X X11)
46         )
47
48         ecm_src_configure
49 }