kde-frameworks/kimageformats: arm64 stable (bug #690096)
[gentoo.git] / kde-frameworks / kimageformats / kimageformats-5.60.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_QTHELP="false"
7 VIRTUALX_REQUIRED="test"
8 inherit kde5
9
10 DESCRIPTION="Framework providing additional format plugins for Qt's image I/O system"
11 LICENSE="LGPL-2+"
12 KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
13 IUSE="eps openexr"
14
15 DEPEND="
16         $(add_frameworks_dep karchive)
17         $(add_qt_dep qtgui)
18         eps? ( $(add_qt_dep qtprintsupport) )
19         openexr? (
20                 media-libs/ilmbase:=
21                 media-libs/openexr:=
22         )
23 "
24 RDEPEND="${DEPEND}"
25
26 DOCS=( src/imageformats/AUTHORS )
27
28 src_configure() {
29         local mycmakeargs=(
30                 $(cmake-utils_use_find_package eps Qt5PrintSupport)
31                 $(cmake-utils_use_find_package openexr OpenEXR)
32         )
33
34         kde5_src_configure
35 }