www-client/opera: Old.
[gentoo.git] / kde-frameworks / ki18n / ki18n-5.36.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
7 inherit kde5 python-single-r1
8
9 DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
10 LICENSE="LGPL-2+"
11 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 IUSE=""
13
14 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
15
16 RDEPEND="${PYTHON_DEPS}
17         $(add_qt_dep qtscript)
18         sys-devel/gettext
19         virtual/libintl
20 "
21 DEPEND="${RDEPEND}
22         test? (
23                 $(add_qt_dep qtconcurrent)
24                 $(add_qt_dep qtdeclarative)
25         )
26 "
27
28 pkg_setup() {
29         kde5_pkg_setup
30         python-single-r1_pkg_setup
31 }
32
33 src_install() {
34         kde5_src_install
35         python_fix_shebang "${ED}/usr/$(get_libdir)/cmake/KF5I18n/ts-pmap-compile.py"
36 }