dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / kde-frameworks / kholidays / kholidays-5.67.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_QTHELP="false"
7 ECM_TEST="true"
8 QTMIN=5.12.3
9 inherit ecm kde.org
10
11 DESCRIPTION="Library to determine holidays and other special events for a geographical region"
12 LICENSE="LGPL-2.1+"
13 KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
14 IUSE="nls"
15
16 BDEPEND="
17         nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
18 "
19 DEPEND="
20         >=dev-qt/qtdeclarative-${QTMIN}:5
21 "
22 RDEPEND="${DEPEND}
23         !kde-apps/kholidays:5
24 "
25
26 src_test() {
27         # bug 624214
28         mkdir -p "${HOME}/.local/share/kf5/libkholidays" || die
29         cp -r "${S}/holidays/plan2" "${HOME}/.local/share/kf5/libkholidays/" || die
30         ecm_src_test
31 }