d5b13e09f2905c24c989c23859d5ee46b90b4cfe
[gentoo.git] / kde-frameworks / kdesu / kdesu-5.54.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="false"
7 inherit kde5
8
9 DESCRIPTION="Framework to handle super user actions"
10 LICENSE="LGPL-2"
11 KEYWORDS="amd64 ~arm ~arm64 x86"
12 IUSE="X"
13
14 RDEPEND="
15         $(add_frameworks_dep kconfig)
16         $(add_frameworks_dep kcoreaddons)
17         $(add_frameworks_dep ki18n)
18         $(add_frameworks_dep kpty)
19         $(add_frameworks_dep kservice)
20         X? ( x11-libs/libX11 )
21 "
22 DEPEND="${RDEPEND}
23         X? ( x11-base/xorg-proto )
24 "
25
26 src_configure() {
27         local mycmakeargs=(
28                 $(cmake-utils_use_find_package X X11)
29         )
30
31         kde5_src_configure
32 }