kde-frameworks: Restore stable versions
[gentoo.git] / kde-frameworks / kdesu / kdesu-5.18.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KDE_TEST="false"
8 inherit kde5
9
10 DESCRIPTION="Framework to handle super user actions"
11 LICENSE="LGPL-2"
12 KEYWORDS="~amd64 ~arm ~x86"
13 IUSE="X"
14
15 RDEPEND="
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kcoreaddons)
18         $(add_frameworks_dep ki18n)
19         $(add_frameworks_dep kpty)
20         $(add_frameworks_dep kservice)
21         X? ( x11-libs/libX11 )
22 "
23 DEPEND="${RDEPEND}
24         X? ( x11-proto/xproto )
25 "
26
27 src_configure() {
28         local mycmakeargs=(
29                 $(cmake-utils_use_find_package X X11)
30         )
31
32         kde5_src_configure
33 }