884fa5a4331938e9fbcf6b71a56f7f934a09edfa
[gentoo.git] / kde-frameworks / kcrash / kcrash-5.37.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5
8
9 DESCRIPTION="Framework for intercepting and handling application crashes"
10 LICENSE="LGPL-2+"
11 KEYWORDS="amd64 ~arm ~arm64 x86"
12 IUSE="nls"
13
14 # requires running kde environment
15 RESTRICT+=" test"
16
17 RDEPEND="
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kwindowsystem)
20         $(add_qt_dep qtgui)
21         $(add_qt_dep qtx11extras)
22         x11-libs/libX11
23 "
24 DEPEND="${RDEPEND}
25         x11-proto/xproto
26         nls? ( $(add_qt_dep linguist-tools) )
27         test? ( $(add_qt_dep qtwidgets) )
28 "