dev-util/kdbg: Drop 3.0.0-r1
[gentoo.git] / kde-frameworks / kcoreaddons / kcoreaddons-5.65.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 QTMIN=5.12.3
7 inherit ecm kde.org
8
9 DESCRIPTION="Framework for solving common problems such as caching, randomisation, and more"
10 LICENSE="LGPL-2+"
11 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
12 IUSE="fam nls"
13
14 BDEPEND="
15         nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
16 "
17 DEPEND="
18         >=dev-qt/qtcore-${QTMIN}:5[icu]
19         fam? ( virtual/fam )
20 "
21 RDEPEND="${DEPEND}"
22
23 src_configure() {
24         local mycmakeargs=(
25                 -D_KDE4_DEFAULT_HOME_POSTFIX=4
26                 $(cmake_use_find_package fam FAM)
27         )
28
29         ecm_src_configure
30 }
31
32 src_test() {
33         # bugs: 619656, 632398, 647414, 665682
34         local myctestargs=(
35                 -j1
36                 -E "(kautosavefiletest|kdirwatch_qfswatch_unittest|kdirwatch_stat_unittest|kformattest)"
37         )
38
39         ecm_src_test
40 }