kde-frameworks/knotifications: x86 stable wrt bug 670862
[gentoo.git] / kde-frameworks / karchive / karchive-5.52.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="Framework for reading, creation, and manipulation of various archive formats"
9 LICENSE="GPL-2 LGPL-2.1"
10 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
11 IUSE="+bzip2 +lzma"
12
13 RDEPEND="
14         bzip2? ( app-arch/bzip2 )
15         lzma? ( app-arch/xz-utils )
16         sys-libs/zlib
17 "
18 DEPEND="${RDEPEND}"
19
20 src_configure() {
21         local mycmakeargs=(
22                 $(cmake-utils_use_find_package bzip2 BZip2)
23                 $(cmake-utils_use_find_package lzma LibLZMA)
24         )
25
26         kde5_src_configure
27 }