dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / kde-frameworks / kapidox / kapidox-5.67.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_SINGLE_IMPL="true"
7 PYTHON_COMPAT=( python3_{6,7,8} )
8 inherit cmake kde.org distutils-r1
9
10 DESCRIPTION="Framework for building KDE API documentation in a standard format and style"
11 LICENSE="BSD-2"
12 KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
13 IUSE=""
14
15 RDEPEND="
16         app-doc/doxygen
17         $(python_gen_cond_dep '
18                 dev-python/jinja[${PYTHON_MULTI_USEDEP}]
19                 dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
20         ')
21         media-gfx/graphviz[python,${PYTHON_SINGLE_USEDEP}]
22 "
23
24 pkg_setup() {
25         python-single-r1_pkg_setup
26 }