kde-frameworks: Add KDE Frameworks 5.46.0
[gentoo.git] / kde-frameworks / breeze-icons-rcc / breeze-icons-rcc-5.46.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_AUTODEPS="false"
7 KDE_DEBUG="false"
8 KDE_QTHELP="false"
9 KMNAME="breeze-icons"
10 inherit kde5
11
12 DESCRIPTION="Breeze SVG icon theme binary resource"
13 LICENSE="LGPL-3"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="
18         $(add_frameworks_dep extra-cmake-modules)
19         $(add_qt_dep qtcore)
20         test? (
21                 $(add_qt_dep qttest)
22                 app-misc/fdupes
23         )
24 "
25 RDEPEND=""
26
27 src_configure() {
28         local mycmakeargs=(
29                 -DBINARY_ICONS_RESOURCE=ON
30                 -DSKIP_INSTALL_ICONS=ON
31         )
32         kde5_src_configure
33 }