808b0534e8358abaee6fc65059e0246cab2e3c2e
[gentoo.git] / kde-frameworks / bluez-qt / bluez-qt-5.37.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIRTUALX_REQUIRED="test"
7 inherit kde5 udev
8
9 DESCRIPTION="Qt wrapper for Bluez 5 DBus API"
10 LICENSE="LGPL-2"
11 KEYWORDS="amd64 ~arm x86"
12 IUSE=""
13
14 DEPEND="
15         $(add_qt_dep qtdbus)
16         $(add_qt_dep qtdeclarative)
17         $(add_qt_dep qtnetwork)
18 "
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}/${P}-tests.patch" )
22
23 src_configure() {
24         local mycmakeargs=(
25                 -DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d"
26         )
27
28         kde5_src_configure
29 }
30
31 src_test() {
32         # bug: 609248
33         local myctestargs=( -j1 )
34
35         kde5_src_test
36 }