Merge remote-tracking branch 'github/pr/359'.
[gentoo.git] / kde-base / korganizer / korganizer-4.14.10.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KDE_HANDBOOK="optional"
8 KMNAME="kdepim"
9 EGIT_BRANCH="KDE/4.14"
10 inherit kde4-meta
11
12 DESCRIPTION="A Personal Organizer for KDE"
13 HOMEPAGE="https://www.kde.org/applications/office/korganizer/"
14 KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
15 IUSE="debug"
16
17 DEPEND="
18         $(add_kdebase_dep kdepimlibs 'akonadi(+)')
19         $(add_kdebase_dep kdepim-common-libs)
20         sys-libs/zlib
21 "
22 RDEPEND="${DEPEND}
23         $(add_kdeapps_dep ktimezoned '' 4.14.3)
24 "
25
26 RESTRICT="test"
27 # bug 393135
28
29 KMLOADLIBS="kdepim-common-libs"
30
31 KMEXTRA="
32         korgac/
33 "
34 KMEXTRACTONLY="
35         agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml
36         akonadi_next/
37         calendarviews/
38         kdgantt2/
39         kmail/
40         knode/org.kde.knode.xml
41         libkdepimdbusinterfaces/
42         libkleo/
43         libkpgp/
44         mailimporter/
45         messagecomposer/
46 "
47 KMCOMPILEONLY="
48         calendarsupport/
49         grantleetheme/
50         incidenceeditor-ng/
51         kaddressbookgrantlee/
52         mailcommon/
53         messagecore/
54         messageviewer/
55         pimcommon/
56         templateparser/
57 "
58
59 src_unpack() {
60         if use kontact; then
61                 KMEXTRA="${KMEXTRA}
62                         kontact/plugins/planner/
63                         kontact/plugins/specialdates/
64                 "
65         fi
66
67         kde4-meta_src_unpack
68 }
69
70 src_prepare() {
71         use handbook && epatch "${FILESDIR}/${PN}-4.14.10-handbook.patch"
72
73         kde4-meta_src_prepare
74 }
75
76 src_install() {
77         kde4-meta_src_install
78         # colliding with kdepim-common-libs
79         rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
80         rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
81 }
82
83 pkg_postinst() {
84         kde4-meta_pkg_postinst
85
86         if ! has_version kde-base/kdepim-kresources:${SLOT}; then
87                 echo
88                 elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
89                 echo
90         fi
91 }