Merge remote-tracking branch 'github/pr/519'.
[gentoo.git] / kde-base / kmail / kmail-4.4.2015.06.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KMNAME="kdepim"
8 KDE_HANDBOOK=optional
9 VIRTUALX_REQUIRED=test
10 inherit flag-o-matic kde4-meta
11
12 DESCRIPTION="Email component of Kontact, the integrated personal information manager of KDE (noakonadi branch)"
13 KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
14 IUSE="debug"
15
16 DEPEND="
17         $(add_kdebase_dep kdelibs '' 4.13.1)
18         $(add_kdebase_dep kdepimlibs '' 4.13.1)
19         $(add_kdebase_dep libkdepim '' 4.4.11.1-r1)
20         $(add_kdebase_dep libkleo)
21         $(add_kdebase_dep libkpgp)
22 "
23 RDEPEND="${DEPEND}"
24
25 KMEXTRACTONLY="
26         korganizer/org.kde.Korganizer.Calendar.xml
27         libkleo/
28         libkpgp/
29 "
30 KMEXTRA="
31         kmailcvt/
32         ksendemail/
33         libksieve/
34         messagecore/
35         messagelist/
36         messageviewer/
37         mimelib/
38         plugins/kmail/
39 "
40 KMLOADLIBS="libkdepim"
41
42 PATCHES=(
43         "${FILESDIR}/${PN}-4.4.9-nodbus.patch"
44 )
45
46 src_configure() {
47         # Bug 308903
48         use ppc64 && append-flags -mminimal-toc
49
50         mycmakeargs=(
51                 -DWITH_IndicateQt=OFF
52         )
53
54         kde4-meta_src_configure
55 }
56
57 src_compile() {
58         kde4-meta_src_compile kmail_xml
59         kde4-meta_src_compile
60 }
61
62 pkg_postinst() {
63         kde4-meta_pkg_postinst
64
65         if ! has_version kde-base/kdepim-kresources:${SLOT}; then
66                 echo
67                 elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
68                 echo
69         fi
70         if ! has_version kde-base/kleopatra:${SLOT}; then
71                 echo
72                 elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
73                 echo
74         fi
75 }