dev-lang/vala: p.masked bump to 0.45.3
[gentoo.git] / kde-apps / libkgeomap / libkgeomap-18.12.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_TEST="true"
7 VIRTUALX_REQUIRED="test"
8 inherit kde5
9
10 DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
11 HOMEPAGE="https://www.digikam.org/"
12
13 LICENSE="GPL-2+"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND="
18         $(add_frameworks_dep kconfig)
19         $(add_frameworks_dep kcoreaddons)
20         $(add_frameworks_dep ki18n)
21         $(add_frameworks_dep kio)
22         $(add_kdeapps_dep marble 'kde' '' '5=')
23         $(add_qt_dep qtconcurrent)
24         $(add_qt_dep qtgui)
25         >=dev-qt/qtwebkit-5.212.0_pre20180120:5
26         $(add_qt_dep qtwidgets)
27         $(add_qt_dep qtxml)
28 "
29 RDEPEND="${DEPEND}"
30
31 src_configure() {
32         use test && local mycmakeargs=( -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true )
33
34         kde5_src_configure
35 }