app-portage/repoman: make repoman-2.3.8 require portage-2.3.27
[gentoo.git] / kde-apps / libkgeomap / libkgeomap-17.08.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="true"
7 VIRTUALX_REQUIRED="test"
8 inherit kde5
9
10 DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
11 HOMEPAGE="https://www.digikam.org/"
12
13 LICENSE="GPL-2+"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND="
18         $(add_frameworks_dep kconfig)
19         $(add_frameworks_dep kcoreaddons)
20         $(add_frameworks_dep ki18n)
21         $(add_frameworks_dep kio)
22         $(add_kdeapps_dep marble 'kde' '' '5=')
23         $(add_qt_dep qtconcurrent)
24         $(add_qt_dep qtgui)
25         $(add_qt_dep qtwebkit)
26         $(add_qt_dep qtwidgets)
27         $(add_qt_dep qtxml)
28 "
29 RDEPEND="${DEPEND}"
30
31 src_configure() {
32         local mycmakeargs=(
33                 -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true
34         )
35
36         kde5_src_configure
37 }