kde-apps: Drop KDE Applications 18.08.3
[gentoo.git] / kde-apps / ktp-auth-handler / ktp-auth-handler-18.12.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit kde5
7
8 DESCRIPTION="KDE Telepathy authentication handler"
9 HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
10
11 LICENSE="LGPL-2.1"
12 KEYWORDS="amd64 ~arm64 x86"
13 IUSE=""
14
15 DEPEND="
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kcoreaddons)
18         $(add_frameworks_dep ki18n)
19         $(add_frameworks_dep kio)
20         $(add_frameworks_dep kwallet)
21         $(add_frameworks_dep kwidgetsaddons)
22         $(add_kdeapps_dep kaccounts-integration)
23         $(add_kdeapps_dep ktp-common-internals)
24         $(add_qt_dep qtdbus)
25         $(add_qt_dep qtgui)
26         $(add_qt_dep qtnetwork)
27         $(add_qt_dep qtwidgets)
28         app-crypt/qca:2[qt5(+)]
29         net-libs/accounts-qt
30         net-libs/signond
31         net-libs/telepathy-qt[qt5(+)]
32 "
33 RDEPEND="${DEPEND}
34         app-crypt/qca:2[ssl]
35 "