b6281d77cc2c62d3e8587d09a209514526cf231c
[gentoo.git] / kde-apps / krfb / krfb-17.08.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_HANDBOOK="forceoptional"
7 inherit kde5
8
9 DESCRIPTION="VNC-compatible server to share Plasma desktops"
10 HOMEPAGE="https://www.kde.org/applications/system/krfb/"
11 KEYWORDS="amd64 x86"
12 IUSE=""
13
14 DEPEND="
15         $(add_frameworks_dep kcompletion)
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kconfigwidgets)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kcrash)
20         $(add_frameworks_dep kdbusaddons)
21         $(add_frameworks_dep kdnssd)
22         $(add_frameworks_dep ki18n)
23         $(add_frameworks_dep knotifications)
24         $(add_frameworks_dep kwallet)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_frameworks_dep kxmlgui)
27         $(add_qt_dep qtdbus)
28         $(add_qt_dep qtgui)
29         $(add_qt_dep qtnetwork)
30         $(add_qt_dep qtwidgets)
31         $(add_qt_dep qtx11extras)
32         >=net-libs/libvncserver-0.9.9
33         x11-libs/libX11
34         x11-libs/libxcb
35         x11-libs/libXtst
36         x11-libs/xcb-util-image
37 "
38 RDEPEND="${DEPEND}"