app-portage/repoman: make repoman-2.3.8 require portage-2.3.27
[gentoo.git] / kde-apps / knavalbattle / knavalbattle-17.08.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_HANDBOOK="forceoptional"
7 KDE_SELINUX_MODULE="games"
8 inherit kde5
9
10 DESCRIPTION="Battleship clone by KDE"
11 HOMEPAGE="
12         https://www.kde.org/applications/games/navalbattle/
13         https://games.kde.org/game.php?game=kbattleship
14 "
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND="
19         $(add_frameworks_dep kcompletion)
20         $(add_frameworks_dep kconfig)
21         $(add_frameworks_dep kcoreaddons)
22         $(add_frameworks_dep kcrash)
23         $(add_frameworks_dep kdbusaddons)
24         $(add_frameworks_dep kdnssd)
25         $(add_frameworks_dep ki18n)
26         $(add_frameworks_dep ktextwidgets)
27         $(add_frameworks_dep kwidgetsaddons)
28         $(add_frameworks_dep kxmlgui)
29         $(add_kdeapps_dep libkdegames)
30         $(add_qt_dep qtgui)
31         $(add_qt_dep qtnetwork)
32         $(add_qt_dep qtwidgets)
33         $(add_qt_dep qtxml)
34 "
35 RDEPEND="${DEPEND}"
36
37 DOCS=( AUTHORS )