profiles: Mask kde-apps/kcalcore, kde-apps/kcontacts for removal
[gentoo.git] / kde-apps / kmplot / kmplot-19.04.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_HANDBOOK="forceoptional"
7 inherit kde5
8
9 DESCRIPTION="Mathematical function plotter"
10 HOMEPAGE="https://kde.org/applications/education/kmplot https://edu.kde.org/kmplot/"
11 KEYWORDS="amd64 arm64 x86"
12 IUSE=""
13
14 DEPEND="
15         $(add_frameworks_dep kcompletion)
16         $(add_frameworks_dep kconfig)
17         $(add_frameworks_dep kconfigwidgets)
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kcrash)
20         $(add_frameworks_dep kguiaddons)
21         $(add_frameworks_dep ki18n)
22         $(add_frameworks_dep kparts)
23         $(add_frameworks_dep kservice)
24         $(add_frameworks_dep ktextwidgets)
25         $(add_frameworks_dep kwidgetsaddons)
26         $(add_frameworks_dep kxmlgui)
27         $(add_qt_dep qtdbus)
28         $(add_qt_dep qtgui)
29         $(add_qt_dep qtprintsupport)
30         $(add_qt_dep qtsvg)
31         $(add_qt_dep qtwidgets)
32         $(add_qt_dep qtxml)
33 "
34 RDEPEND="${DEPEND}"