78018288734884801a60339c53b1d948087a3a93
[gentoo.git] / kde-apps / kldap / kldap-17.08.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_HANDBOOK="forceoptional"
7 KDE_TEST="true"
8 inherit kde5
9
10 DESCRIPTION="Library for interacting with LDAP servers"
11 LICENSE="GPL-2+"
12 KEYWORDS="amd64 x86"
13 IUSE=""
14
15 DEPEND="
16         $(add_frameworks_dep kcompletion)
17         $(add_frameworks_dep ki18n)
18         $(add_frameworks_dep kio)
19         $(add_frameworks_dep kwidgetsaddons)
20         $(add_qt_dep qtgui)
21         $(add_qt_dep qtwidgets)
22         dev-libs/cyrus-sasl
23         net-nds/openldap
24 "
25 RDEPEND="${DEPEND}
26         !kde-apps/kdepim-l10n
27 "
28
29 src_prepare() {
30         kde5_src_prepare
31
32         if ! use_if_iuse handbook ; then
33                 sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
34                         -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
35         fi
36 }