www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / kde-apps / kitinerary / kitinerary-20.04.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_TEST="true"
7 PVCUT=$(ver_cut 1-3)
8 KFMIN=5.70.0
9 QTMIN=5.12.3
10 VIRTUALX_REQUIRED="test"
11 inherit ecm kde.org
12
13 DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
14 HOMEPAGE="https://kde.org/applications/office/org.kde.kontact"
15
16 LICENSE="LGPL-2.1+"
17 SLOT="5"
18 KEYWORDS="~amd64 ~arm64 ~x86"
19 IUSE="+barcode pdf"
20
21 DEPEND="
22         >=dev-qt/qtdeclarative-${QTMIN}:5
23         >=dev-qt/qtgui-${QTMIN}:5
24         >=kde-frameworks/karchive-${KFMIN}:5
25         >=kde-frameworks/kcalendarcore-${KFMIN}:5
26         >=kde-frameworks/kcontacts-${KFMIN}:5
27         >=kde-frameworks/ki18n-${KFMIN}:5
28         >=kde-apps/kmime-${PVCUT}:5
29         >=kde-apps/kpkpass-${PVCUT}:5
30         sys-libs/zlib
31         barcode? ( media-libs/zxing-cpp )
32         pdf? ( app-text/poppler:=[qt5] )
33 "
34 RDEPEND="${DEPEND}
35         !<kde-apps/kdepim-addons-18.07.80
36 "
37
38 src_configure() {
39         local mycmakeargs=(
40                 $(cmake_use_find_package barcode ZXing)
41                 $(cmake_use_find_package pdf Poppler)
42         )
43         ecm_src_configure
44 }