Convert URIs for gnome.org and kde.org to https
[gentoo.git] / kde-apps / kget / kget-4.14.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KDE_HANDBOOK="optional"
8 inherit kde4-base
9
10 DESCRIPTION="An advanced download manager for KDE"
11 HOMEPAGE="https://www.kde.org/applications/internet/kget/"
12 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
13 IUSE="debug bittorrent gpg mms sqlite webkit"
14
15 RDEPEND="
16         app-crypt/qca:2[qt4]
17         $(add_kdeapps_dep libkonq)
18         $(add_kdebase_dep libkworkspace '' 4.11)
19         bittorrent? ( >=net-libs/libktorrent-1.0.3 )
20         gpg? ( $(add_kdebase_dep kdepimlibs) )
21         mms? ( media-libs/libmms )
22         sqlite? ( dev-db/sqlite:3 )
23         webkit? ( >=kde-misc/kwebkitpart-0.9.6 )
24 "
25 DEPEND="${RDEPEND}
26         dev-libs/boost
27 "
28
29 src_configure() {
30         local mycmakeargs=(
31                 -DWITH_NepomukCore=OFF
32                 -DWITH_NepomukWidgets=OFF
33                 $(cmake-utils_use_with bittorrent KTorrent)
34                 $(cmake-utils_use_with gpg QGpgme)
35                 $(cmake-utils_use_with mms LibMms)
36                 $(cmake-utils_use_with sqlite)
37                 $(cmake-utils_use_with webkit KWebKitPart)
38         )
39         kde4-base_src_configure
40 }