proj/gentoo: Initial commit
[gentoo.git] / kde-apps / kget / kget-4.14.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KDE_HANDBOOK="optional"
8 inherit kde4-base
9
10 DESCRIPTION="An advanced download manager for KDE"
11 HOMEPAGE="http://www.kde.org/applications/internet/kget/"
12 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
13 IUSE="debug bittorrent gpg mms nepomuk sqlite webkit"
14
15 RDEPEND="
16         app-crypt/qca:2[qt4(+)]
17         $(add_kdebase_dep kdelibs 'nepomuk?')
18         $(add_kdeapps_dep libkonq)
19         $(add_kdebase_dep libkworkspace '' 4.11)
20         bittorrent? ( >=net-libs/libktorrent-1.0.3 )
21         gpg? ( $(add_kdebase_dep kdepimlibs) )
22         mms? ( media-libs/libmms )
23         nepomuk? (
24                 dev-libs/shared-desktop-ontologies
25                 dev-libs/soprano
26                 $(add_kdebase_dep nepomuk-core)
27                 $(add_kdebase_dep nepomuk-widgets)
28         )
29         sqlite? ( dev-db/sqlite:3 )
30         webkit? ( >=kde-misc/kwebkitpart-0.9.6 )
31 "
32 DEPEND="${RDEPEND}
33         dev-libs/boost
34 "
35
36 src_configure() {
37         local mycmakeargs=(
38                 $(cmake-utils_use_with bittorrent KTorrent)
39                 $(cmake-utils_use_with gpg QGpgme)
40                 $(cmake-utils_use_with mms LibMms)
41                 $(cmake-utils_use_with nepomuk NepomukCore)
42                 $(cmake-utils_use_with nepomuk NepomukWidgets)
43                 $(cmake-utils_use_with sqlite)
44                 $(cmake-utils_use_with webkit KWebKitPart)
45         )
46         kde4-base_src_configure
47 }