kde-apps: Add KDE Applications 18.08.1
[gentoo.git] / kde-apps / kdepim-runtime / kdepim-runtime-18.08.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_HANDBOOK="forceoptional"
7 KDE_TEST="forceoptional"
8 VIRTUALX_REQUIRED="test"
9 inherit kde5
10
11 DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
12 LICENSE="GPL-2+ LGPL-2.1+"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="speech"
15
16 # TODO kolab
17 CDEPEND="
18         $(add_frameworks_dep kcodecs)
19         $(add_frameworks_dep kcompletion)
20         $(add_frameworks_dep kconfig)
21         $(add_frameworks_dep kconfigwidgets)
22         $(add_frameworks_dep kcoreaddons)
23         $(add_frameworks_dep kdbusaddons)
24         $(add_frameworks_dep kholidays)
25         $(add_frameworks_dep ki18n)
26         $(add_frameworks_dep kio)
27         $(add_frameworks_dep kitemmodels)
28         $(add_frameworks_dep kjobwidgets)
29         $(add_frameworks_dep knotifications)
30         $(add_frameworks_dep knotifyconfig)
31         $(add_frameworks_dep kservice)
32         $(add_frameworks_dep ktextwidgets)
33         $(add_frameworks_dep kwallet)
34         $(add_frameworks_dep kwidgetsaddons)
35         $(add_frameworks_dep kwindowsystem)
36         $(add_frameworks_dep kxmlgui)
37         $(add_kdeapps_dep akonadi)
38         $(add_kdeapps_dep akonadi-calendar)
39         $(add_kdeapps_dep akonadi-contacts)
40         $(add_kdeapps_dep akonadi-mime)
41         $(add_kdeapps_dep akonadi-notes)
42         $(add_kdeapps_dep kalarmcal)
43         $(add_kdeapps_dep kcalcore)
44         $(add_kdeapps_dep kcalutils)
45         $(add_kdeapps_dep kcontacts)
46         $(add_kdeapps_dep kdav)
47         $(add_kdeapps_dep kidentitymanagement)
48         $(add_kdeapps_dep kimap)
49         $(add_kdeapps_dep kmailtransport)
50         $(add_kdeapps_dep kmbox)
51         $(add_kdeapps_dep kmime)
52         $(add_kdeapps_dep libkgapi)
53         $(add_kdeapps_dep pimcommon)
54         $(add_qt_dep qtdbus)
55         $(add_qt_dep qtgui)
56         $(add_qt_dep qtnetwork)
57         $(add_qt_dep qtwebengine 'widgets')
58         $(add_qt_dep qtwidgets)
59         $(add_qt_dep qtxml)
60         dev-libs/cyrus-sasl:2
61         dev-libs/libical:=
62         speech? ( $(add_qt_dep qtspeech) )
63 "
64 DEPEND="${CDEPEND}
65         $(add_qt_dep qtxmlpatterns)
66         dev-libs/libxslt
67         test? ( $(add_kdeapps_dep kimap 'test') )
68 "
69 RDEPEND="${CDEPEND}
70         !kde-apps/kdepim-l10n
71         !kde-misc/akonadi-ews
72         $(add_frameworks_dep oxygen-icons)
73 "
74
75 RESTRICT+=" test"
76
77 src_prepare() {
78         kde5_src_prepare
79         # We don't build kolab, so we can disable this
80         punt_bogus_dep KF5 KDELibs4Support
81 }
82
83 src_configure() {
84         local mycmakeargs=(
85                 $(cmake-utils_use_find_package speech Qt5TextToSpeech)
86         )
87
88         kde5_src_configure
89 }