kde-apps/kdenetwork-filesharing: x86 stable wrt bug #612776
[gentoo.git] / kde-apps / kdenetwork-filesharing / kdenetwork-filesharing-16.12.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="kcontrol filesharing config module for SMB"
9 KEYWORDS="amd64 x86"
10 IUSE=""
11
12 DEPEND="
13         $(add_frameworks_dep kcompletion)
14         $(add_frameworks_dep kcoreaddons)
15         $(add_frameworks_dep ki18n)
16         $(add_frameworks_dep kio)
17         $(add_frameworks_dep kwidgetsaddons)
18         $(add_qt_dep qtgui)
19         $(add_qt_dep qtwidgets)
20 "
21 RDEPEND="${DEPEND}"
22
23 src_configure() {
24         local mycmakeargs=(
25                 -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
26         )
27
28         kde5_src_configure
29 }