app-portage/repoman: make repoman-2.3.8 require portage-2.3.27
[gentoo.git] / kde-apps / kaccounts-integration / kaccounts-integration-17.08.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 KDE_TEST="forceoptional"
7 VIRTUALDBUS_TEST="true"
8 inherit kde5
9
10 DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
11 HOMEPAGE="https://community.kde.org/KTp"
12 LICENSE="LGPL-2.1"
13
14 KEYWORDS="amd64 ~arm x86"
15 IUSE=""
16
17 RDEPEND="
18         $(add_frameworks_dep kconfigwidgets)
19         $(add_frameworks_dep kcoreaddons)
20         $(add_frameworks_dep kdbusaddons)
21         $(add_frameworks_dep kdeclarative)
22         $(add_frameworks_dep ki18n)
23         $(add_qt_dep qtdbus)
24         $(add_qt_dep qtdeclarative)
25         $(add_qt_dep qtgui)
26         $(add_qt_dep qtwidgets)
27         net-libs/accounts-qt
28         >=net-libs/libaccounts-glib-1.21
29         net-libs/signond
30 "
31 DEPEND="${RDEPEND}
32         $(add_frameworks_dep kcmutils)
33         $(add_plasma_dep kde-cli-tools)
34         sys-devel/gettext
35 "
36
37 # bug #549444
38 RESTRICT+=" test"