profiles: Mask kde-apps/kcalcore, kde-apps/kcontacts for removal
[gentoo.git] / kde-apps / dolphin-plugins-bazaar / dolphin-plugins-bazaar-19.04.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KMNAME="dolphin-plugins"
7 KDE_HANDBOOK="false"
8 MY_PLUGIN_NAME="bazaar"
9 inherit kde5
10
11 DESCRIPTION="Dolphin plugin for Bazaar integration"
12 KEYWORDS="amd64 arm64 x86"
13 IUSE=""
14
15 DEPEND="
16         $(add_frameworks_dep kcoreaddons)
17         $(add_frameworks_dep ki18n)
18         $(add_frameworks_dep kio)
19         $(add_frameworks_dep ktextwidgets)
20         $(add_kdeapps_dep dolphin)
21         $(add_qt_dep qtgui)
22         $(add_qt_dep qtwidgets)
23 "
24 RDEPEND="${DEPEND}
25         !kde-apps/dolphin-plugins:5
26         dev-vcs/bzr
27 "
28
29 src_prepare() {
30         kde5_src_prepare
31         # kxmlgui, qtnetwork only required by dropbox
32         punt_bogus_dep Qt5 Network
33         punt_bogus_dep KF5 XmlGui
34         # delete non-${PN} translations
35         if [[ ${KDE_BUILD_TYPE} = release ]]; then
36                 find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
37         fi
38 }
39
40 src_configure() {
41         local mycmakeargs=(
42                 -DBUILD_${MY_PLUGIN_NAME}=ON
43                 -DBUILD_dropbox=OFF
44                 -DBUILD_git=OFF
45                 -DBUILD_hg=OFF
46                 -DBUILD_svn=OFF
47         )
48         kde5_src_configure
49 }