dev-lang/vala: p.masked bump to 0.45.3
[gentoo.git] / kde-apps / dolphin / dolphin-18.12.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_HANDBOOK="forceoptional"
7 KDE_TEST="true"
8 VIRTUALX_REQUIRED="test"
9 inherit kde5
10
11 DESCRIPTION="Plasma filemanager focusing on usability"
12 HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
13 KEYWORDS="amd64 ~arm64 x86"
14 IUSE="semantic-desktop +thumbnail"
15
16 DEPEND="
17         $(add_frameworks_dep kbookmarks)
18         $(add_frameworks_dep kcmutils)
19         $(add_frameworks_dep kcodecs)
20         $(add_frameworks_dep kcompletion)
21         $(add_frameworks_dep kconfig)
22         $(add_frameworks_dep kconfigwidgets)
23         $(add_frameworks_dep kcoreaddons)
24         $(add_frameworks_dep kcrash)
25         $(add_frameworks_dep kdbusaddons)
26         $(add_frameworks_dep ki18n)
27         $(add_frameworks_dep kiconthemes)
28         $(add_frameworks_dep kinit)
29         $(add_frameworks_dep kio)
30         $(add_frameworks_dep kitemviews)
31         $(add_frameworks_dep kjobwidgets)
32         $(add_frameworks_dep knewstuff)
33         $(add_frameworks_dep knotifications)
34         $(add_frameworks_dep kparts)
35         $(add_frameworks_dep kservice)
36         $(add_frameworks_dep ktextwidgets)
37         $(add_frameworks_dep kwidgetsaddons)
38         $(add_frameworks_dep kxmlgui)
39         $(add_frameworks_dep solid)
40         $(add_qt_dep qtconcurrent)
41         $(add_qt_dep qtdbus)
42         $(add_qt_dep qtgui)
43         $(add_qt_dep qtwidgets)
44         $(add_qt_dep qtxml)
45         media-libs/phonon[qt5(+)]
46         semantic-desktop? (
47                 $(add_frameworks_dep baloo)
48                 $(add_frameworks_dep kfilemetadata)
49                 $(add_kdeapps_dep baloo-widgets)
50         )
51 "
52 RDEPEND="${DEPEND}
53         $(add_kdeapps_dep kio-extras)
54         thumbnail? (
55                 $(add_kdeapps_dep ffmpegthumbs)
56                 $(add_kdeapps_dep thumbnailers)
57         )
58 "
59
60 RESTRICT+=" test"
61
62 src_configure() {
63         local mycmakeargs=(
64                 $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
65                 $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
66                 $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
67         )
68
69         kde5_src_configure
70 }
71
72 pkg_postinst() {
73         kde5_pkg_postinst
74
75         if [[ -z "${REPLACING_VERSIONS}" ]]; then
76                 has_version "kde-apps/ark:${SLOT}" || \
77                         elog "For compress/extract and other actions install kde-apps/ark:${SLOT}"
78
79                 has_version "kde-apps/kleopatra:${SLOT}" || \
80                         elog "For crypto actions install kde-apps/kleopatra:${SLOT}"
81         fi
82 }