dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / kde-apps / calendarjanitor / calendarjanitor-20.04.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
7 ECM_TEST="false"
8 KDE_ORG_NAME="akonadi-calendar-tools"
9 PVCUT=$(ver_cut 1-3)
10 KFMIN=5.70.0
11 QTMIN=5.12.3
12 inherit ecm kde.org
13
14 DESCRIPTION="Tool to scan calendar data for buggy instances"
15
16 LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
17 SLOT="5"
18 KEYWORDS="~amd64 ~arm64 ~x86"
19 IUSE=""
20
21 DEPEND="
22         >=dev-qt/qtwidgets-${QTMIN}:5
23         >=kde-apps/akonadi-${PVCUT}:5
24         >=kde-apps/akonadi-calendar-${PVCUT}:5
25         >=kde-apps/calendarsupport-${PVCUT}:5
26         >=kde-frameworks/kcalendarcore-${KFMIN}:5
27         >=kde-frameworks/kcoreaddons-${KFMIN}:5
28         >=kde-frameworks/ki18n-${KFMIN}:5
29 "
30 RDEPEND="${DEPEND}"
31
32 src_prepare() {
33         ecm_src_prepare
34
35         cmake_comment_add_subdirectory doc konsolekalendar
36         sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
37
38         # delete colliding konsolekalendar translations
39         if [[ ${KDE_BUILD_TYPE} = release ]]; then
40                 rm -f po/*/konsolekalendar.po || die
41                 rm -rf po/*/docs/konsolekalendar || die
42         fi
43 }