dev-lang/vala: p.masked bump to 0.45.3
[gentoo.git] / kde-apps / calendarjanitor / calendarjanitor-18.12.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
7 KDE_TEST="false"
8 KMNAME="akonadi-calendar-tools"
9 inherit kde5
10
11 DESCRIPTION="Tool to scan calendar data for buggy instances"
12 LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
13 KEYWORDS="amd64 ~arm64 x86"
14
15 IUSE=""
16
17 DEPEND="
18         $(add_frameworks_dep kcoreaddons)
19         $(add_frameworks_dep kdelibs4support)
20         $(add_frameworks_dep ki18n)
21         $(add_kdeapps_dep akonadi '' 18.12.3-r1)
22         $(add_kdeapps_dep akonadi-calendar)
23         $(add_kdeapps_dep calendarsupport)
24         $(add_kdeapps_dep kcalcore)
25         $(add_qt_dep qtwidgets)
26 "
27 RDEPEND="${DEPEND}
28         !kde-apps/kdepim-l10n
29 "
30
31 src_prepare() {
32         kde5_src_prepare
33
34         cmake_comment_add_subdirectory doc konsolekalendar
35         sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
36
37         # delete colliding konsolekalendar translations
38         if [[ ${KDE_BUILD_TYPE} = release ]]; then
39                 rm -f po/*/konsolekalendar.po || die
40                 rm -rf po/*/docs/konsolekalendar || die
41         fi
42 }