dev-lang/vala: p.masked bump to 0.45.3
[gentoo.git] / kde-apps / akonadi-search / akonadi-search-18.12.3-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_TEST="forceoptional"
7 VIRTUALX_REQUIRED="test"
8 inherit kde5
9
10 DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
11 HOMEPAGE="https://cgit.kde.org/akonadi-search.git"
12 LICENSE="GPL-2+ LGPL-2.1+"
13 KEYWORDS="amd64 ~arm64 x86"
14 IUSE=""
15
16 BDEPEND="
17         test? ( $(add_kdeapps_dep akonadi 'tools' 18.12.3-r1) )
18 "
19 COMMON_DEPEND="
20         $(add_frameworks_dep kcmutils)
21         $(add_frameworks_dep kcodecs)
22         $(add_frameworks_dep kconfig)
23         $(add_frameworks_dep kconfigwidgets)
24         $(add_frameworks_dep kcoreaddons)
25         $(add_frameworks_dep kdbusaddons)
26         $(add_frameworks_dep kio)
27         $(add_frameworks_dep ki18n)
28         $(add_frameworks_dep krunner)
29         $(add_kdeapps_dep akonadi '' 18.12.3-r1)
30         $(add_kdeapps_dep akonadi-mime)
31         $(add_kdeapps_dep kcalcore)
32         $(add_kdeapps_dep kcontacts)
33         $(add_kdeapps_dep kmime)
34         $(add_qt_dep qtdbus)
35         $(add_qt_dep qtgui)
36         $(add_qt_dep qtwidgets)
37         >=dev-libs/xapian-1.3:=[chert(+)]
38 "
39 DEPEND="${COMMON_DEPEND}
40         dev-libs/boost
41         test? ( $(add_kdeapps_dep akonadi 'mysql,postgres,sqlite' 18.12.3-r1) )
42 "
43 RDEPEND="${COMMON_DEPEND}
44         !kde-apps/kdepim-l10n
45 "
46
47 PATCHES=( "${FILESDIR}/${PN}-18.12.0-cmake.patch" )