Merge remote-tracking branch 'github/pr/656'.
[gentoo.git] / java-virtuals / servlet-api / servlet-api-2.5-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit java-virtuals-2
8
9 DESCRIPTION="Virtual for servlet api"
10 HOMEPAGE="http://java.sun.com/products/servlet/"
11 SRC_URI=""
12
13 LICENSE="public-domain"
14 SLOT="${PV}"
15 KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
16 IUSE=""
17
18 RDEPEND="|| (
19                 dev-java/tomcat-servlet-api:${SLOT}
20                 dev-java/resin-servlet-api:${SLOT}
21                 dev-java/glassfish-servlet-api:${SLOT}
22         )"
23
24 JAVA_VIRTUAL_PROVIDES="tomcat-servlet-api-${SLOT} resin-servlet-api-${SLOT} glassfish-servlet-api-${SLOT}"