www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / gui-libs / amtk / amtk-5.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2
7
8 DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
9 HOMEPAGE="https://wiki.gnome.org/Projects/Amtk"
10
11 LICENSE="LGPL-2.1+"
12 SLOT="5"
13 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
14 IUSE="+introspection"
15
16 RDEPEND="
17         >=dev-libs/glib-2.52:2
18         >=x11-libs/gtk+-3.22:3
19         introspection? ( >=dev-libs/gobject-introspection-1.42:= )
20 "
21 DEPEND="${DEPEND}
22         >=sys-devel/gettext-0.19.6
23         dev-util/glib-utils
24         >=dev-util/gtk-doc-am-1.25
25         virtual/pkgconfig
26 "
27
28 src_configure() {
29         gnome2_src_configure \
30                 --disable-gtk-doc \
31                 --disable-installed-tests \
32                 $(use_enable introspection) \
33                 --disable-valgrind
34 }