dev-qt/qtxml: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / gnustep-libs / dbuskit / dbuskit-0.1.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools gnustep-2
6
7 DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
8 HOMEPAGE="https://github.com/gnustep/libs-dbuskit"
9 SRC_URI="https://github.com/gnustep/libs-dbuskit/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 DEPEND=">=sys-apps/dbus-1.2.1"
17 RDEPEND="${DEPEND}"
18
19 PATCHES=( ${FILESDIR}/${P}-remove_gc.patch )
20
21 S=${WORKDIR}/libs-${P}
22
23 src_prepare() {
24         default
25
26         if ! use doc; then
27                 # Remove doc target
28                 sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
29                         || die "doc sed failed"
30         fi
31
32         # Bug 410697
33         sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
34                 -i configure.ac || die "ObjectiveC2 runtime sed failed"
35
36         eautoreconf
37 }