gnustep-base/gnustep-base: 1.27.0 bump
[gentoo.git] / gnustep-base / gnustep-base / gnustep-base-1.27.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit eutils gnustep-base
6
7 DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
8 HOMEPAGE="http://www.gnustep.org"
9 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
10
11 LICENSE="GPL-2 LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
14 IUSE="+gnutls +icu +libffi zeroconf"
15
16 RDEPEND="${GNUSTEP_CORE_DEPEND}
17         >=gnustep-base/gnustep-make-2.6.0
18         gnutls? ( net-libs/gnutls )
19         icu? ( >=dev-libs/icu-49.0:= )
20         !libffi? ( dev-libs/ffcall
21                 gnustep-base/gnustep-make[-native-exceptions] )
22         libffi? ( dev-libs/libffi )
23         >=dev-libs/libxml2-2.6
24         >=dev-libs/libxslt-1.1
25         >=dev-libs/gmp-4.1:=
26         >=sys-libs/zlib-1.2
27         zeroconf? ( net-dns/avahi )"
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig"
30
31 PATCHES=( "${FILESDIR}"/${PN}-1.26.0-no_compress_man.patch )
32
33 src_configure() {
34         egnustep_env
35
36         local myconf
37         if use libffi ; then
38                 myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
39         else
40                 myconf="--disable-libffi --enable-ffcall"
41         fi
42
43         myconf="$myconf $(use_enable gnutls tls)"
44         myconf="$myconf $(use_enable icu)"
45         myconf="$myconf $(use_enable zeroconf)"
46         myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
47         myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
48         myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
49
50         econf $myconf
51 }
52
53 src_install() {
54         # We need to set LD_LIBRARY_PATH because the doc generation program
55         # uses the gnustep-base libraries.  Since egnustep_env "cleans the
56         # environment" including our LD_LIBRARY_PATH, we're left no choice
57         # but doing it like this.
58
59         egnustep_env
60         egnustep_install
61
62         if use doc ; then
63                 export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
64                 egnustep_doc
65         fi
66         egnustep_install_config
67 }