gnustep-base/gnustep-back-cairo: sparc stable wrt bug #579232
[gentoo.git] / gnustep-base / gnustep-back-cairo / gnustep-back-cairo-0.23.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit gnustep-base
7
8 DESCRIPTION="Cairo back-end component for the GNUstep GUI Library"
9 HOMEPAGE="http://www.gnustep.org"
10 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
15 IUSE="opengl xim"
16
17 RDEPEND="${GNUSTEP_CORE_DEPEND}
18         =gnustep-base/gnustep-gui-${PV%.*}*
19         opengl? ( virtual/opengl virtual/glu )
20         x11-libs/libICE
21         x11-libs/libSM
22         x11-libs/libX11
23         x11-libs/libXext
24         x11-libs/libXi
25         x11-libs/libXmu
26         x11-libs/libXt
27         x11-libs/libXft
28         x11-libs/libXrender
29         >=media-libs/freetype-2.1.9
30
31         >=x11-libs/cairo-1.2.0[X]
32
33         !gnustep-base/gnustep-back-art
34         !gnustep-base/gnustep-back-xlib"
35 DEPEND="${RDEPEND}
36         virtual/pkgconfig"
37
38 S=${WORKDIR}/gnustep-back-${PV}
39
40 src_configure() {
41         egnustep_env
42
43         myconf="$(use_enable opengl glx)"
44         myconf="$myconf $(use_enable xim)"
45         myconf="$myconf --enable-server=x11"
46         myconf="$myconf --enable-graphics=cairo"
47
48         econf $myconf
49 }