gnustep-base/gnustep-base: fix compressed man pages install
[gentoo.git] / gnustep-base / gnustep-back-art / gnustep-back-art-0.25.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnustep-base
6
7 DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
8 HOMEPAGE="http://www.gnustep.org"
9 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
14 IUSE="opengl xim"
15
16 RDEPEND="${GNUSTEP_CORE_DEPEND}
17         =gnustep-base/gnustep-gui-${PV%.*}*
18         opengl? ( virtual/opengl virtual/glu )
19         x11-libs/libICE
20         x11-libs/libSM
21         x11-libs/libX11
22         x11-libs/libXext
23         x11-libs/libXi
24         x11-libs/libXmu
25         x11-libs/libXt
26         x11-libs/libXft
27         x11-libs/libXrender
28         >=media-libs/freetype-2.1.9
29
30         >=media-libs/libart_lgpl-2.3
31         >=gnustep-base/mknfonts-0.5-r1
32         media-fonts/dejavu
33
34         !gnustep-base/gnustep-back-cairo
35         !gnustep-base/gnustep-back-xlib"
36 DEPEND="${RDEPEND}"
37
38 S=${WORKDIR}/gnustep-back-${PV}
39
40 src_configure() {
41         egnustep_env
42
43         myconf="$(use_enable opengl glx)"
44         myconf="$myconf $(use_enable xim)"
45         myconf="$myconf --enable-server=x11"
46         myconf="$myconf --enable-graphics=art"
47
48         econf $myconf
49 }
50
51 src_compile() {
52         gnustep-base_src_compile
53
54         # Create font lists for DejaVu
55         einfo "Generating nfonts support files"
56         (
57                 cd Fonts
58                 export "${GS_ENV[@]}"
59                 ${GNUSTEP_SYSTEM_TOOLS}/mknfonts \
60                         $(fc-list : file|grep -v '\.gz'|cut -d: -f1) \
61                         || die "nfonts support files creation failed"
62                 # Trim whitepsaces
63                 for fdir in *\ */; do
64                         mv "$fdir" `echo $fdir | tr -d [:space:]`
65                 done
66         )
67 }
68
69 src_install() {
70         gnustep-base_src_install
71
72         mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
73         cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
74 }
75
76 gnustep_config_script() {
77         echo "echo ' * setting normal font to DejaVuSans'"
78         echo "defaults write NSGlobalDomain NSFont DejaVuSans"
79         echo "echo ' * setting bold font to DejaVuSans-Bold'"
80         echo "defaults write NSGlobalDomain NSBoldFont DejaVuSans-Bold"
81         echo "echo ' * setting fixed font to DejaVuSansMono'"
82         echo "defaults write NSGlobalDomain NSUserFixedPitchFont DejaVuSansMono"
83 }