Merge remote-tracking branch 'github/pr/1591'
[gentoo.git] / gnustep-apps / cynthiune / cynthiune-1.0.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit gnustep-2
7
8 MY_P=${P/c/C}
9 DESCRIPTION="Free software and romantic music player for GNUstep"
10 HOMEPAGE="http://gap.nongnu.org/cynthiune/"
11 SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
12
13 KEYWORDS="~amd64 ~ppc ~x86"
14 LICENSE="GPL-2"
15 SLOT="0"
16
17 IUSE="alsa ao flac mad modplug musepack oss timidity vorbis"
18
19 # musicbrainz disabled upstream for now
20 RDEPEND="media-libs/audiofile
21         media-libs/taglib
22         alsa? ( media-libs/alsa-lib )
23         ao? ( media-libs/libao )
24         flac? ( media-libs/flac )
25         mad? ( media-libs/libid3tag
26                 media-libs/libmad )
27         musepack? ( >=media-sound/musepack-tools-444 )
28         modplug? ( media-libs/libmodplug )
29         timidity? ( media-sound/timidity++ )
30         vorbis? ( >=media-libs/libogg-1.1.2
31                 >=media-libs/libvorbis-1.0.1-r2 )"
32 DEPEND="${RDEPEND}
33         mad? ( virtual/pkgconfig )"
34
35 S=${WORKDIR}/${MY_P}
36
37 cynthiune_get_config() {
38         local myconf="disable-windowsmedia=yes disable-esound=yes"
39         use alsa || myconf="${myconf} disable-alsa=yes"
40         use ao || myconf="${myconf} disable-ao=yes"
41         use flac || myconf="${myconf} disable-flac=yes disable-flactags=yes"
42         use mad || myconf="${myconf} disable-mp3=yes disable-id3tag=yes"
43         use modplug || myconf="${myconf} disable-mod=yes"
44         use musepack || myconf="${myconf} disable-musepack=yes"
45         use oss || myconf="${myconf} disable-oss=yes"
46         use timidity || myconf="${myconf} disable-timidity=yes"
47         use vorbis || myconf="${myconf} disable-ogg=yes disable-vorbistags=yes"
48
49         echo ${myconf}
50 }
51
52 src_compile() {
53         egnustep_env
54         egnustep_make "$(cynthiune_get_config)"
55 }
56
57 src_install() {
58         egnustep_env
59         egnustep_install "$(cynthiune_get_config)"
60 }