profiles/package.mask: remove rackspace-novaclient related packages
[gentoo.git] / gnustep-apps / cdplayer / cdplayer-0.6.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit gnustep-2
6
7 DESCRIPTION="Small CD Audio Player for GNUstep"
8 HOMEPAGE="https://github.com/schik/cdplayer"
9 SRC_URI="https://github.com/schik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 KEYWORDS="~amd64 ~x86"
12 LICENSE="GPL-2"
13 SLOT="0"
14
15 IUSE="dbus"
16 DEPEND="dev-libs/libcdio
17         dev-libs/libcdio-paranoia
18         gnustep-apps/cynthiune
19         dbus? ( gnustep-libs/dbuskit )"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23         sed -e "s#cdda.h#paranoia/cdda.h#" \
24                 -e "s#paranoia.h#paranoia/paranoia.h#" \
25                 -i AudioCD/AudioCD.h || die "AudioCD.h sed failed"
26 }
27
28 src_compile() {
29         local myconf=""
30         use dbus || myconf="${myconf} notifications=no"
31
32         egnustep_env
33         egnustep_make ${myconf}
34 }