gnome-extra/evolution-ews: remove old
[gentoo.git] / gnome-extra / pch-session / pch-session-3.30.0.2.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome2-utils
6
7 DESCRIPTION="Unofficial gnome based session with different default settings and extensions"
8 HOMEPAGE="https://gitlab.com/pachoramos/pch-session"
9 SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64"
14 IUSE=""
15
16 # gnome-extra/gnome-tweaks to configure extensions easily
17 RDEPEND="
18         >=gnome-base/gnome-shell-3.30
19         gnome-extra/gnome-shell-extensions
20         gnome-extra/gnome-shell-extension-applications-overview-tooltip
21         gnome-extra/gnome-shell-extension-dash-to-panel
22         gnome-extra/gnome-shell-extension-desktop-icons
23         gnome-extra/gnome-shell-extension-gsconnect
24         gnome-extra/gnome-shell-extensions-topicons-plus
25         gnome-extra/gnome-tweaks
26 "
27 BDEPEND=""
28 DEPEND=""
29
30 src_install() {
31         insinto /usr
32         doins -r usr/.
33         einstalldocs
34 }
35
36 pkg_postinst() {
37         gnome2_schemas_update
38 }
39
40 pkg_postrm() {
41         gnome2_schemas_update
42 }