Merge remote-tracking branch 'github/pr/2027'
[gentoo.git] / gnome-extra / nm-applet / nm-applet-1.0.10.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 GCONF_DEBUG="no"
7 GNOME2_LA_PUNT="yes"
8 GNOME_ORG_MODULE="network-manager-applet"
9
10 inherit gnome2
11
12 DESCRIPTION="GNOME applet for NetworkManager"
13 HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
14
15 LICENSE="GPL-2+"
16 SLOT="0"
17 IUSE="bluetooth +introspection modemmanager"
18 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
19
20 RDEPEND="
21         app-crypt/libsecret
22         >=dev-libs/glib-2.32:2[dbus]
23         >=dev-libs/dbus-glib-0.88
24         >=sys-apps/dbus-1.4.1
25         >=sys-auth/polkit-0.96-r1
26         >=x11-libs/gtk+-3.4:3[introspection?]
27         >=x11-libs/libnotify-0.7.0
28
29         app-text/iso-codes
30         >=net-misc/networkmanager-1.0.0[introspection?]
31         net-misc/mobile-broadband-provider-info
32
33         bluetooth? ( >=net-wireless/gnome-bluetooth-2.27.6:= )
34         introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
35         modemmanager? ( >=net-misc/modemmanager-0.7.990 )
36         virtual/freedesktop-icon-theme
37         virtual/libgudev:=
38 "
39 DEPEND="${RDEPEND}
40         virtual/pkgconfig
41         >=dev-util/intltool-0.50.1
42 "
43
44 PDEPEND="virtual/notification-daemon" #546134
45
46 src_configure() {
47         gnome2_src_configure \
48                 --disable-more-warnings \
49                 --disable-static \
50                 --disable-migration \
51                 --localstatedir=/var \
52                 $(use_with bluetooth) \
53                 $(use_enable introspection) \
54                 $(use_with modemmanager modem-manager-1)
55 }