work around parallel make issues - bug #561380
[gentoo.git] / gnome-extra / nautilus-actions / nautilus-actions-3.2.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 GCONF_DEBUG="no"
7 GNOME2_LA_PUNT="yes"
8
9 inherit gnome2
10
11 DESCRIPTION="Configures programs to be launched when files are selected in Nautilus"
12 HOMEPAGE="http://www.nautilus-actions.org/ https://git.gnome.org/browse/nautilus-actions/"
13
14 LICENSE="GPL-2 FDL-1.3"
15 SLOT="3"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-libs/glib-2.30:2
21         >=dev-libs/libxml2-2.6:2
22         dev-libs/libunique:3
23         >=gnome-base/libgtop-2.23.1:2
24         >=gnome-base/nautilus-3
25         sys-apps/util-linux
26         x11-libs/gdk-pixbuf:2
27         x11-libs/gtk+:3
28         x11-libs/libICE
29         >=x11-libs/libSM-1
30
31         !gnome-extra/nautilus-actions:2
32 "
33 DEPEND="${RDEPEND}
34         dev-util/gdbus-codegen
35         >=dev-util/intltool-0.35.5
36         virtual/pkgconfig
37 "
38
39 src_prepare() {
40         # install docs in /usr/share/doc/${PF}, not ${P}
41         sed -i -e "s:/doc/@PACKAGE@-@VERSION@:/doc/${PF}:g" \
42                 Makefile.{am,in} \
43                 docs/Makefile.{am,in} \
44                 docs/nact/Makefile.{am,in} || die
45         gnome2_src_prepare
46 }
47
48 src_configure() {
49         gnome2_src_configure \
50                 --enable-deprecated \
51                 --disable-gconf \
52                 --with-gtk=3
53 }
54
55 src_install() {
56         gnome2_src_install
57         # Do not install COPYING
58         rm -v "${ED}usr/share/doc/${PF}"/COPYING* || die
59 }