dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / gnome-extra / libgsf / libgsf-1.14.46.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="The GNOME Structured File Library"
8 HOMEPAGE="https://developer.gnome.org/gsf/"
9
10 LICENSE="GPL-2 LGPL-2.1"
11 SLOT="0/114" # libgsf-1.so version
12 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
13 IUSE="bzip2 gtk +introspection"
14
15 RDEPEND="
16         >=dev-libs/glib-2.34:2
17         >=dev-libs/libxml2-2.4.16:2
18         sys-libs/zlib
19         bzip2? ( app-arch/bzip2 )
20         gtk? (
21                 x11-libs/gdk-pixbuf:2
22                 virtual/imagemagick-tools
23                 )
24         introspection? ( >=dev-libs/gobject-introspection-1:= )
25 "
26 DEPEND="${RDEPEND}
27         >=dev-util/gtk-doc-am-1.12
28         dev-libs/gobject-introspection-common
29         >=sys-devel/gettext-0.19.4
30         virtual/pkgconfig
31 "
32
33 src_configure() {
34         gnome2_src_configure \
35                 --disable-static \
36                 $(use_with bzip2 bz2) \
37                 $(use_enable introspection) \
38                 $(use_with gtk gdk-pixbuf)
39 }