gnome-extra/libgsf: version bump
[gentoo.git] / gnome-extra / gtkhtml / gtkhtml-4.8.5.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7
8 inherit gnome2
9
10 DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
11 HOMEPAGE="https://git.gnome.org/browse/gtkhtml"
12
13 LICENSE="GPL-2+ LGPL-2+"
14 SLOT="4.0"
15 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
16 IUSE=""
17
18 # orbit is referenced in configure, but is not used anywhere else
19 RDEPEND="
20         >=x11-libs/gtk+-3.2:3
21         >=x11-libs/cairo-1.10:=
22         x11-libs/pango
23         >=app-text/enchant-1.1.7:=
24         gnome-base/gsettings-desktop-schemas
25         >=app-text/iso-codes-0.49
26         >=net-libs/libsoup-2.26.0:2.4
27 "
28 DEPEND="${RDEPEND}
29         x11-proto/xproto
30         sys-devel/gettext
31         >=dev-util/intltool-0.40.0
32         virtual/pkgconfig
33 "
34
35 src_configure() {
36         gnome2_src_configure --disable-static
37 }
38
39 src_install() {
40         gnome2_src_install
41
42         # Don't collide with 3.14 slot
43         mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
44 }