57d3fb7bf343fdb4f151199ef0ddeac05d3f5aae
[gentoo.git] / gnome-extra / gtkhtml / gtkhtml-4.10.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 GNOME2_EAUTORECONF="yes"
6
7 inherit gnome2
8
9 DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
10 HOMEPAGE="https://gitlab.gnome.org/Archive/gtkhtml"
11
12 LICENSE="GPL-2+ LGPL-2+"
13 SLOT="4.0"
14 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 # orbit is referenced in configure, but is not used anywhere else
18 RDEPEND="
19         >=x11-libs/gtk+-3.2:3
20         >=x11-libs/cairo-1.10:=
21         x11-libs/pango
22         app-text/enchant:2
23         gnome-base/gsettings-desktop-schemas
24         >=app-text/iso-codes-0.49
25         >=net-libs/libsoup-2.26.0:2.4
26 "
27 DEPEND="${RDEPEND}
28         x11-base/xorg-proto
29         sys-devel/gettext
30         dev-util/glib-utils
31         >=dev-util/intltool-0.40.0
32         virtual/pkgconfig
33 "
34
35 PATCHES=(
36          "${FILESDIR}"/enchant-2.patch
37 )
38
39 src_configure() {
40         gnome2_src_configure --disable-static
41 }
42
43 src_install() {
44         gnome2_src_install
45
46         # Don't collide with 3.14 slot
47         mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
48 }