sys-devel/gcc-config: arm64 stable (bug #711382)
[gentoo.git] / gnome-extra / gnome-weather / gnome-weather-3.32.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit gnome.org gnome2-utils meson xdg
7
8 DESCRIPTION="A weather application for GNOME"
9 HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
10
11 LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm64 x86"
14
15 DEPEND="
16         >=dev-libs/glib-2.32:2
17         >=dev-libs/gobject-introspection-1.56:=
18         >=x11-libs/gtk+-3.20:3
19         >=dev-libs/gjs-1.50
20         >=app-misc/geoclue-2.3.1:2.0
21         >=dev-libs/libgweather-3.28:=
22 "
23 RDEPEND="${DEPEND}
24         gnome-base/gsettings-desktop-schemas
25 "
26 # libxml2 required for glib-compile-resources
27 BDEPEND="
28         dev-libs/appstream-glib
29         dev-libs/libxml2:2
30         >=sys-devel/gettext-0.19.8
31         virtual/pkgconfig
32 "
33 # Tests have a lot of issues, starting with reliance on a system installation,
34 # accessing the network and other intermittent failures with network-sandbox disabled
35 # https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
36 # test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
37 RESTRICT="test"
38
39 src_configure() {
40         meson_src_configure -Dprofile=default
41 }
42
43 pkg_postinst() {
44         xdg_pkg_postinst
45         gnome2_schemas_update
46 }
47
48 pkg_postrm() {
49         xdg_pkg_postrm
50         gnome2_schemas_update
51 }