sys-libs/libomp: Bump to 7.0.0rc3
[gentoo.git] / gnome-extra / gnome-tweak-tool / gnome-tweak-tool-3.24.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME2_LA_PUNT="yes"
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit gnome2 python-r1
9
10 DESCRIPTION="Tool to customize GNOME 3 options"
11 HOMEPAGE="https://wiki.gnome.org/action/show/Apps/GnomeTweakTool"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15
16 IUSE=""
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
18
19 KEYWORDS="amd64 ~ia64 x86"
20
21 COMMON_DEPEND="
22         ${PYTHON_DEPS}
23         dev-libs/glib:2[dbus]
24         >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
25         >=gnome-base/gsettings-desktop-schemas-3.23.3
26 "
27 # g-s-d, gnome-desktop, gnome-shell etc. needed at runtime for the gsettings schemas
28 RDEPEND="${COMMON_DEPEND}
29         >=gnome-base/gnome-desktop-3.6.0.1:3=[introspection]
30         >=x11-libs/gtk+-3.12:3[introspection]
31
32         net-libs/libsoup:2.4[introspection]
33         x11-libs/libnotify[introspection]
34
35         >=gnome-base/gnome-settings-daemon-3
36         >=gnome-base/gnome-shell-3.24
37         >=gnome-base/nautilus-3
38 "
39 DEPEND="${COMMON_DEPEND}
40         >=dev-util/intltool-0.40.0
41         virtual/pkgconfig
42 "
43
44 src_prepare() {
45         # Add contents of Gentoo's cursor theme directory to cursor theme list
46         eapply "${FILESDIR}/${PN}-3.10.1-gentoo-cursor-themes.patch"
47
48         gnome2_src_prepare
49         python_copy_sources
50 }
51
52 src_configure() {
53         python_foreach_impl run_in_build_dir gnome2_src_configure
54 }
55
56 src_compile() {
57         python_foreach_impl run_in_build_dir gnome2_src_compile
58 }
59
60 src_test() {
61         python_foreach_impl run_in_build_dir default
62 }
63
64 src_install() {
65         install_python() {
66                 gnome2_src_install
67                 python_doscript gnome-tweak-tool || die
68         }
69         python_foreach_impl run_in_build_dir install_python
70 }