www-servers/apache: ia64 stable, bug #624868
[gentoo.git] / gnome-extra / gnome-dvb-daemon / gnome-dvb-daemon-0.2.90.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6 PYTHON_COMPAT=( python{3_4,3_5} )
7 VALA_MIN_API_VERSION="0.26"
8
9 inherit eutils gnome2 multilib python-any-r1 vala
10
11 DESCRIPTION="Setup your DVB devices, record and watch TV shows and browse EPG using GStreamer"
12 HOMEPAGE="https://wiki.gnome.org/action/show/Projects/DVBDaemon"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64"
17 IUSE="nls totem vala"
18
19 RDEPEND=">=dev-libs/glib-2.32.0:2
20         >=media-libs/gstreamer-1.4.0:1.0
21         >=media-libs/gst-plugins-good-1.4.0:1.0
22         >=media-libs/gst-plugins-bad-1.4.0:1.0
23         >=dev-libs/libgee-0.8:0.8
24         >=dev-db/sqlite-3.4:3
25         >=media-libs/gst-rtsp-server-1.4.5:1.0
26         media-plugins/gst-plugins-dvb:1.0
27         dev-python/gst-python:1.0
28         >=dev-python/pygobject-3.2.1:3
29         >=dev-libs/gobject-introspection-1.44.0:0
30         x11-libs/gtk+:3[introspection]
31         virtual/libgudev:0
32         vala? ( $(vala_depend) )
33         totem? ( media-video/totem )"
34 DEPEND="${RDEPEND}
35         ${PYTHON_DEPS}
36         >=dev-lang/perl-5.8.1:0
37         >=dev-util/intltool-0.40.0:0
38         >=dev-libs/libltdl-2.2.6:0
39         virtual/pkgconfig:0
40         nls? ( >=sys-devel/gettext-0.18.1:0 )"
41
42 pkg_setup() {
43         python-any-r1_pkg_setup
44 }
45
46 src_prepare() {
47         python_fix_shebang .
48         gnome2_src_prepare
49         if use vala ; then
50                 vala_src_prepare
51         fi
52 }
53
54 src_configure() {
55         # Prevent sandbox violations, bug #569992
56         addpredict /dev
57         gnome2_src_configure \
58                 $(use_enable nls) \
59                 $(use_enable totem totem-plugin) \
60                 $(usex totem '--with-totem-plugin-dir=/usr/$(get_libdir)/totem/plugins' '')
61 }
62
63 pkg_postinst() {
64         if use totem ; then
65                 python_optimize
66         fi
67         gnome2_pkg_postinst
68 }
69
70 pkg_postrm() {
71         if use totem ; then
72                 python_optimize
73         fi
74         gnome2_pkg_postrm
75 }